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Keeping Current 
The latest versions of this document and the KD Data Pro software are available for downloading 
free of charge on the Internet at www.teamkd.com.  We recommend that you use Netscape Navigator 
4.x or higher, or Microsoft Internet Explorer 4.x or higher to download these files. 
 
K.D. Engineering can also send this document and/or the KD Data Pro at a nominal cost.  For more 
information call K.D. Engineering at (800) 308-7717. 
 
 



 

May-10 © 2010 K.D. Engineering  iii

Table of Contents 
 

Introduction ........................................................................................................................................... 5 
Installing the KD DATA PRO Software ............................................................................................... 6 

System Requirements ......................................................................................................................... 6 
Installation Instructions ...................................................................................................................... 6 

Using the KD Data Pro Software .......................................................................................................... 7 
Using the Monitor Menu ....................................................................................................................... 8 

Retrieving Logged Data ..................................................................................................................... 8 
Setting the Date and Time .................................................................................................................. 8 
Edit Walk Thru Locations .................................................................................................................. 9 
Resetting the Data Logger Memory ................................................................................................... 9 
Updating the IAQ Monitor .............................................................................................................. 10 
Obtaining Current Data Logger Information ................................................................................... 11 
Adjusting Download Options .......................................................................................................... 12 
Configuring an Analog Channel (this option is currently available only for custom 
configurations) ............................................................................................................................... 14 

Defining a New Analog Channel .............................................................................................. 14 
Uploading an Analog Channel ................................................................................................. 14 
To Delete an analog channel ..................................................................................................... 15 

Using the Data Menu ........................................................................................................................... 16 
Adding Notes to .IAQ Files ............................................................................................................. 16 
Viewing Information About Your File ............................................................................................ 17 
Creating and Manipulating Graphs .................................................................................................. 17 

Creating a Graph .......................................................................................................................... 17 
Manipulating a Graph ................................................................................................................... 18 

Using the Graph Menu ............................................................................................................. 18 
Naming a Graph .................................................................................................................... 18 
Changing the Data Axes ....................................................................................................... 19 
Changing the Color of Your Data Axes ................................................................................ 20 
Changing the Font of Your Data Axes .................................................................................. 21 
Adding Static Lines to Your Graph ...................................................................................... 22 
Adding Labeled or Unlabelled Ticks to Your Time Axis ..................................................... 23 
Changing the Color of Your Time Axis ................................................................................ 23 
Changing the Font of Your Time Axis ................................................................................. 24 
Changing the Scale of Your Graph ....................................................................................... 25 
Zooming into Specified Areas of Your Graph ...................................................................... 26 
Zooming out of Specified Areas of Your Graph ................................................................... 27 

Creating and Manipulating Reports ................................................................................................. 28 
Creating a Report ......................................................................................................................... 28 
Manipulating a Report .................................................................................................................. 28 

Using the Report Menu ............................................................................................................. 28 
Naming a Report ................................................................................................................... 28 
Filtering the Data in a Report ................................................................................................ 30 
Controlling Listed Statistics in a Report ............................................................................... 31 

Creating and Manipulating Tables ................................................................................................... 31 
Creating a Table ........................................................................................................................... 31 



 

May-10 © 2010 K.D. Engineering  iv

Manipulating a Table ................................................................................................................... 32 
Using the Table Menu .............................................................................................................. 32 

Naming a Table ..................................................................................................................... 32 
Setting Time and Location Preferences ........................................................................................... 33 

Choosing the Data Range ............................................................................................................. 33 
Changing the Time Display Options ............................................................................................ 34 

Setting Data Preferences .................................................................................................................. 35 
Selecting the Type of Data Shown ............................................................................................... 35 
Selecting Units of Measurement and Data Labels ....................................................................... 36 
Selecting Data Measurement Precision ........................................................................................ 37 

Using the File Menu ............................................................................................................................ 38 
Opening a .KD File .......................................................................................................................... 38 
Closing a .KD File ........................................................................................................................... 38 
Saving a .KD File ............................................................................................................................. 38 
Exporting a .KD File ........................................................................................................................ 39 
Printing a .KD File ........................................................................................................................... 39 
Exiting KD Data Pro Software ........................................................................................................ 39 
 



 

May-10 © 2010 K.D. Engineering 5 

Introduction 
This guide provides information to help you install and use KD DATA PRO. 
 
The following sections are in this guide. 
 
• Installing the KD DATA PRO Software.  This section contains information about installing the 

software. 

• Using the KD DATA PRO Software.  This section contains instructions for using the software to 
display data. 

For information about using your monitor, see the Operator Guide, which should have accompanied 
your monitoring system. 
 
For information about other products available or technical support, call K.D. Engineering toll-free 
at (800) 308-7717. 
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Installing the KD DATA PRO Software 
This section contains system requirement information and instructions for installing the KD DATA 
PRO software. 

System Requirements 
The following system requirements are necessary to run the software. 
 
Microprocessor 486 or higher 
 
Available memory At least 8 MB 
 
Operating system Microsoft Windows 95 or better 

Installation Instructions 
Use the following instructions to install the software. 
 
1. Start Windows. 

2. Insert the CD into the CDROM drive. 

3. The CD should auto run. Follow the onscreen instructions to complete installation. 
(If not, click Start – Run – Browse and select your appropriate CD drive.) 
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Using the KD Data Pro Software 
This section contains information about the tasks you can perform using the KD Data Pro software.  
You can use the software to do the following. 
 
Using the Monitor menu: 

• Retrieve logged data from your instrument 

• Reset the data logger memory 

• Set the current date and time 

• Edit Walk Thru Locations  

• Adjust download options 

• Obtain current data logger information  

• Update your instruments firmware 

• Configure analog channels 

 

Using the Data menu: 

• Add notes to your files 

• Create and manipulate Graphs 

• Create and manipulate Reports 

• Create and manipulate Tables 

• Set Time and Location preferences 

• Set Data preferences 

• Manage Locations 

 

Using the File menu: 

• Open an .KD file 

• Close an .KD file 

• Save an .KD file 

• Export an .KD file 

• Print an .KD file 

• Exit KD Data Pro software 
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Using the Monitor Menu 

Retrieving Logged Data 
Before you can retrieve logged data, ensure the monitor is cabled to your computer and turned on.  
To retrieve logged data from the monitor, select Retrieve Data from the Monitor.  You receive a 
window containing logged data in a table format. 

Setting the Date and Time 
Before you can define the date and time on the monitor, ensure the monitor is cabled to your 
computer and turned on.  In the KD Data Pro window, use the following instructions to define the 
date and time.  The software defaults to the current date and time on your computer. 
 
1.  From the Monitor menu, select Set Date/Time to receive a dialog box with the choice of setting 

the logger time to that of your computer or entering in a time manually. 

 

2.  Choose one and click OK to receive the following warning: 

 

3.  Click OK to proceed, Cancel to retain the monitor’s current Date/Time settings. 

4.  The Date/Time settings are automatically updated on your IAQ monitor, and the data logger is 
reset. 
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Edit Walk Thru Locations 
Use this option to edit, upload and save Walk Thru Locations. 
 
1.  From the Monitor menu, select Edit Walk Thru Locations to receive a dialog box: 

 
2.  Click Add to add location names. 

3.  Click Send To Instrument to upload location names to your IAQ monitor. 

4.  Use the Rename and Delete buttons to modify location names. Use the Move Up and Move 
Down buttons to modify the order of locations. 

5.  Use the Load button to retrieve a previously saved set of locations. Use the Save and Save As 
buttons to save a set of locations – this saves a .KDL file to a folder on your computer for later 
use. 

6.  You can also download a set of location names from the IAQ monitor. Use the Download From 
Instrument button to download names from the instrument. 

Resetting the Data Logger Memory 
Before you can reset the data logger memory of the IAQ monitor, ensure the monitor is cabled to 
your computer and turned on.  In the KD Data Pro window, use the following instructions to reset 
the data logger memory. 
 
1. Select Reset Memory from the Monitor menu to receive the following warning:  
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2. Click OK to proceed, Cancel to retain the monitor’s data. 

3. The monitor’s memory is automatically updated. 

Updating the IAQ Monitor 
Before you can update the IAQ monitor, ensure the monitor is cabled to your computer and turned 
on.  In the KD Data Pro window, do the following to update the AirBoxx firmware on the monitor. 
 
1. From the Monitor menu, select Update Monitor Software to receive an Open window. 

2. From the Look in drop-down list, select the drive and folder containing the .AHX firmware file. 

3. From the folder containing the .AHX firmware file, select the appropriate .AHX file 

4. Click Open to update the IAQ monitor. 
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Obtaining Current Data Logger Information 
Before you can obtain data logger information from the IAQ monitor, ensure the monitor is cabled to 
your computer and turned on.  In the KD Data Pro window, do the following to obtain current data 
logger information. 
 
1. From the Monitor menu, select Get Instrument Properties. 

2. You will receive a dialog box containing current data logger settings and information: 
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3. Use the sensor tabs (e.g. CO2, T, RH, CO) to get information on specific sensors such as units, 
measurement type, accuracy, life remaining, and date of last calibration as well as recommended 
date of next calibration: 

4. Click OK to return to the IAQ Monitor window. 

Adjusting Download Options 
In the KD Data Pro window, do the following to adjust the download speed and choose the 
communication port. 
 
Serial Connection: 
 
1. From the Monitor menu, select Download Options to receive the following dialog box: 
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2. In the Communication Port drop-down list, select the port that is cabled to the IAQ monitor. 

3. In the Communication Speed drop-down list, select either 19200bps or 57600bps. 

 

USB Connection: 

1. Once USB drivers are loaded (see the “Loading USB Drivers” single page instructions), check 
your Device Manager (under Control Panel – System – Hardware) to see what virtual port the 
USB connection is using – i.e. COM X. 

2. In the Communication Port drop-down list, select the port that was listed in the Device 
Manager window. 
Note:  Data transfer at 57600bps is three times faster than 19200bps. If you select the 

57600bps option and experience difficulty, reselect the 19200bps speed. 
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Configuring an Analog Channel 
(this option is currently available only for custom configurations) 
If your AirBoxx is equipped with an analog channel you can upload the details of your external 
sensor so that the AirBoxx will display more meaningful sensor names, readings, and units. 

Defining a New Analog Channel 

1. From the Monitor menu, highlight Analog Channel and select New Configuration File to 
receive the following dialog box: 

 
2. Enter a Long Name (max 24 characters) that will be displayed by the PC software and a Short 

Name (max 8 characters) that will be displayed by the instrument. 

3. Pick a Type of Measure and Units for your sensor. Your instrument must fall into the 
predefined categories or you will have to use generic voltage. 

4. Enter Accuracy for your sensor. The PC software and instrument will use this value to display 
an appropriate number of decimal places, if applicable. 

5. Enter a voltage range for your sensor and a corresponding value so that the instrument can scale 
the sensor voltage. The AirBoxx is capable of reading a maximum of 4 volts. 

6. Click OK to save this configuration for future use. 

 

Uploading an Analog Channel 

1. From the Monitor menu, highlight Analog Channel and select one of the following: 

i. New Configuration File: see Defining a New Analog Channel. 
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ii. Open Configuration File and open a sensor definition previously created and 
saved using the above instructions. 

2. Click on the Upload button to receive the following dialog box (the contents of this box will vary 
depending on the analog channel configuration of your instrument): 

 

3. Select the channel you wish to configure and click on OK. Uploading the channel can take up to 
thirty seconds. 

4. A dialog box will notify you that the configuration is complete or that there was an error. Click 
OK to return to the Analog Channel Configuration dialog box. Click OK to save the 
configuration (if this is a new configuration) or Cancel to dismiss. 

 

To Delete an analog channel 

1. From the Monitor menu, highlight Analog Channel and select Delete Instrument Analog 
Channel to receive the following dialog box: 

 
2. Select the channel you wish to delete and click OK. It can take up to thirty seconds to delete a 

channel. 
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Using the Data Menu 

Adding Notes to .IAQ Files 
In the KD Data Pro window, do the following to add notes to your .KD files. 
 
1. From the Data menu, select Info to receive the following dialog box: 

 
2. In the Info box you may enter notes relevant to the .KD file you are working with such as 

identifying the location and circumstance of the logged data. 

3. Once you have entered any notes, click OK to return to the Monitor window.  The notes will be 
retained with that .KD file, and may be reopened and read or added to at any time. 
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Viewing Information About Your File 
In the KD Data Pro window, do the following to view information. 
 
1. From the Data menu, select Info to receive the following dialog box: 

 
2. Information about your file is displayed as Events. 

 

Creating and Manipulating Graphs 

Creating a Graph 
Note: By default, logged data is presented in table format when initially retrieved (see Retrieve 

Data under Using the Monitor Menu). 

In the KD Data Pro window, do one of the following to create a graph of your logged data. 
 
1. From the Data menu, select New Graph 

or 

click the  button on the toolbar to receive the following dialog box: 
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2. Click No to create a graph of the logged data as it was originally downloaded, or Yes to create a 
graph with previously manipulated time or data options (see Setting Time and Location 
Preferences and Setting Data Preferences for more information). 

3. A graph of the logged data selected is automatically generated. 

Manipulating a Graph 
When a graph is generated, a menu heading entitled Graph automatically appears.  Use this menu to 
manipulate the graph. 

Using the Graph Menu 

Naming a Graph 
In the KD Data Pro window, do the following to title a graph. 
 
1. From the Graph menu select Title to receive the following dialog box: 

 
2. In the Title box, type in the name of the graph. 

3. Click Title Font to change the font, size or color of the title and receive the following dialog 
box: 

 
4. Select the font, style, size and color of the graph title and click OK. 
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5. Click OK in the Graph Title dialog box to return to the KD Data Pro window and apply the 
graph title changes.  Click Cancel in the Graph Title dialog box to cancel your graph title 
changes. 

 
Changing the Data Axes 
This function may be used to change the axis of any of the data lines or add labeled or unlabelled 
ticks to your graph.  This can be useful if your graph line is too flat due to a wide measurement 
range.  In the KD Data Pro window, do the following to change the data axes of your graph. 
 
1. From the Graph menu, select Data Axes to receive the following dialog box: 

 
2. With the Axis tab selected, choose the type of measurement you want to change the axis of, for 

example CO2, Temp, RH, CO. 

3. Click on the check boxes in order to manually enter the Axis Minimum, Axis Maximum, 
Labeled or Unlabelled Tick. 

4. In the Axis Minimum, Axis Maximum, Labeled or Unlabelled Tick boxes enter the desired 
measurements. 

5. Click OK in the Data Axes dialog box to return to the KD Data Pro window and apply the data 
axes changes.  Click Cancel in the Data Axes dialog box to cancel your data axes changes. 
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Changing the Color of Your Data Axes 
This function may be used to change the color of any of the data axes.  In the KD Data Pro window, 
do the following to change the color of the data axes of your graph. 
 
1. From the Graph menu, select Data Axes to receive the following dialog box: 

 
2. With the Axis tab selected, choose the type of measurement for which you want to change the 

axis color, for example CO2, Temp, RH, CO. Click on Axis Color to receive the following 
dialog box: 

 
3. Choose the color you want the axis of the measurement selected to be, and click OK. 

4. Click OK in the Data Axes dialog box to return to the KD Data Pro window and apply the data 
axes color changes.  Click Cancel in the Data Axes dialog box to cancel your data axes color 
changes. 



 

May-10 © 2010 K.D. Engineering  21

Note: You may assign custom colors in the Color dialog box by clicking on Define Custom 
Colors. 

Changing the Font of Your Data Axes 
This function may be used to change the font on any of the data axes.  In the KD Data Pro window, 
do the following to change the font on the data axes of your graph. 
 
1. From the Graph menu, select Data Axes to receive the following dialog box: 

 
2. With the Axis tab selected, choose the type of measurement for which you want to change the 

axis font, for example CO2, Temp, RH, CO. 

3. Click on Axis Font to receive the following dialog box: 

 
4. In the Font dialog box, select the font, style, size and color you want, and click OK. 
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5. Click OK in the Data Axes dialog box to return to the KD Data Pro window and apply font 
changes.  Click Cancel in the Data Axes dialog box to cancel font changes. 

 
 
Adding Static Lines to Your Graph 
This function may be used to add static lines, as reference points, to a graph.  In the KD Data Pro 
window, do the following to add static lines to your graph. 
 
1. From the Graph menu, select Data Axes to receive the following dialog box: 

 
2. With the Static Lines tab selected, choose the type of measurement for which you want to add 

static lines, for example CO2, Temp, RH, CO. 

3. Click in the Show Line check boxes in order to enter Line Values where you want static 
horizontal reference lines to appear on your graph. 

4. Click OK in the Data Axes dialog box to return to the KD Data Pro window and apply the static 
lines you assigned.  Click Cancel in the Data Axes dialog box to cancel the static lines you 
assigned. 
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Adding Labeled or Unlabelled Ticks to Your Time Axis 
This function may be used to add Labeled or Unlabelled Ticks to the time axis of a graph.  This can 
be useful in order to define certain events that may have taken place while logging data.  In the KD 
Data Pro window, do the following to add Labeled or Unlabelled Ticks to the time axis of your 
graph. 
 
1. From the Graph menu, select Time Axis to receive the following dialog box: 

 
2. Click in the Auto check boxes in order to assign Labeled or Unlabelled Ticks. 

3. In the Labeled Tick Every, and Unlabelled Tick Every boxes assign values to the Hours, 
Minutes and Seconds columns. 

4. Click OK in the Time Axis dialog box to return to the KD Data Pro window and apply the 
Labeled and Unlabelled Ticks you assigned to the time axis.  Click Cancel in the Time Axis 
dialog box to cancel the ticks you assigned. 

Changing the Color of Your Time Axis 
This function may be used to change the color of your time axis.  In the KD Data Pro window, do the 
following to change the color of the time axis of your graph. 
 
1. From the Graph menu, select Time Axis to receive the following dialog box: 
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2. Click on Axis Color to receive the following dialog box: 

 
3. Choose the color you want the time axis to be, and click OK. 

4. Click OK in the Time Axis dialog box to return to the KD Data Pro window and apply the time 
axis color changes.  Click Cancel in the Time Axis dialog box to cancel your time axis color 
changes. 

Note: You may assign custom colors in the Color dialog box by clicking on Define Custom 
Colors. 

Changing the Font of Your Time Axis 
This function may be used to change the font on the time axis.  In the KD Data Pro window, do the 
following to change the font on the time axis of your graph. 
 
1. From the Graph menu, select Time Axis to receive the following dialog box: 
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2. Click on Axis Font to receive the following dialog box: 

 
3. In the Font dialog box, select the font, style, size and color you want, and click OK. 

4. Click OK in the Time Axis dialog box to return to the KD Data Pro window and apply the time 
axis font changes.  Click Cancel in the Data Axes dialog box to cancel your time axis font 
changes. 

Changing the Scale of Your Graph 
This function may be used to change the scale of your graph within the active window.  In the KD 
Data Pro window, do the following to change the scale of your graph. 
 
1. From the Graph menu, select Scale to receive the following drop down list: 

 
2. Choose the scale at which you would like to view the graph. 

3. Choose Fit Window to make the graph conform to the size of the active window. 
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4. Choose Other to receive the following dialog box and define the scale yourself: 

 
5. In the Scale Factor box, type in the scale at which you would like to view the graph or, move the 

sliding scale to the percent desired. 

6. Click OK to apply the scale changes, Cancel to return to the KD Data Pro window without 
applying scale changes. 

Notes: By default, graphs are automatically scaled to Fit Window. 

By default, graphs are displayed in portrait format, use Page Setup to alter this default. 

 

 

Zooming into Specified Areas of Your Graph 
This function may be used to examine areas of your graph in more detail.  
There are two ways of zooming into an area of your graph. They are as follows:  
 
1. With a graph active, click the left mouse button and drag out a highlighted section of the graph. 

This area is centered and enlarged to fit your screen. The time line is modified to accommodate 
the new view.  

2. Alternately, center the crosshatch cursor over an area you want to view in greater detail. Click 
the left mouse button while holding down the Ctrl button. This enlarges the graph, centering it 
on wherever the crosshatch cursor was. The time line is modified to accommodate the new view.  
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Zooming out of Specified Areas of Your Graph 
There are two ways of zooming out of an area of your graph. They are as follows:  
 
In order to regain the original scale and view of the graph do the following: 

1. From the Data menu, select Time And Location to receive the following dialog box: 

 
2. On the left side of the dialog box, click in the Display All radio button. 

3. Click OK in the Time Options dialog box to return to the KD Data Pro window and apply the 
data range changes.  Click Cancel in the Time Options dialog box to cancel your data range 
changes. The time line is appended to accommodate the new view. 

4. Alternately, center the crosshatch cursor over an area you want to view at a greater distance. 
Click the left mouse button while holding down the Shift button. This zooms out from the 
graph, centering it on wherever the crosshatch cursor was. The time line is modified to 
accommodate the new view. 
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Creating and Manipulating Reports 

Creating a Report 
Note: By default, logged data is presented in table format when initially retrieved (see Retrieve 

Data under Using the Monitor Menu). 

In the KD Data Pro window, do one of the following to create a report of your logged data. 
 
1. From the Data menu, select New Report 

or 

click the  button on the toolbar to receive the following dialog box: 

 
2. Click No to create a report of the logged data as it was originally downloaded, or Yes to create a 

report with previously manipulated time or data options (see Setting Time and Location 
Preferences and Setting Data Preferences for more information). 

3. A report of the logged data selected is automatically generated. 

Manipulating a Report 
When a report is generated, a menu heading entitled Report automatically appears.  Use this menu to 
manipulate the report. 

Using the Report Menu 

Naming a Report 
In the KD Data Pro window, do the following to title a report. 
 
1. From the Report menu select Title to receive the following dialog box: 

 
2. In the Title box, type in the name of the report. 
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3. Click Title Font to change the font, size or color of the title and receive the following dialog 
box: 

 
4. Select the font, style, size and color of the report title and click OK. 

5. Click OK in the Report Title dialog box to return to the KD Data Pro window and apply the 
report title changes.  Click Cancel in the Report Title dialog box to cancel your report title 
changes. 
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Filtering the Data in a Report 
This function can be used to limit data within a report to certain times or locations.  In the KD Data 
Pro window, do the following to filter the data in a report. 
 
1. From the Report menu, select Report Filter to receive the following dialog box: 

 
2. In the Data Filters dialog box, the Include data with drop down box allows you to select a time 

or location range of data to include in your report.  Fill in the range you want, and click Add 
Criterion. 

3. Click OK in the Data Filters dialog box to return to the KD Data Pro window and apply the 
report filters.  Click Cancel in the Data Filters dialog box to cancel your report filters. 
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Controlling Listed Statistics in a Report 
This function can be used to select what statistics you wish to list in your report.  By default, all 
optional statistics are listed when a report is generated.  In the KD Data Pro window, do the 
following to change the listed statistics in a report. 
 
1. From the Report menu, select Statistic Options to receive the following dialog box: 

 
2. Using the check boxes, decide which statistics you want to include in your report.  Make sure the 

options you want are checked and those you do not want are left unchecked.  Click on check 
boxes to select or deselect options. 

3. Click OK in the Statistical Options dialog box to return to the KD Data Pro window and apply 
the statistic changes to your report.  Click Cancel in the Statistical Options dialog box to 
cancel the changes to your report statistics. 

Creating and Manipulating Tables 

Creating a Table 
Note: By default, logged data is presented in table format when initially retrieved (see Retrieve 

Data under Using the Monitor Menu). 

In the KD Data Pro window, do one of the following to create a report of your logged data. 
 
1. From the Data menu, select New Report or 

click the  button on the toolbar to receive the following dialog box: 

 
2. Click No to create a table of the logged data as it was originally downloaded, or Yes to create a 

table with previously manipulated time or data options (see Setting Time and Location 
Preferences and Setting Data Preferences for more information). 
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3. A table of the logged data selected is automatically generated. 

Manipulating a Table 
When a table is generated, a menu heading entitled Table automatically appears.  Use this menu to 
manipulate the table. 

Using the Table Menu 

Naming a Table 
In the KD Data Pro window, do the following to title a table. 
 
1. From the Table menu select Options to receive the following dialog box: 

 
2. In the Title box, type in the name of the table. 

3. Click Title Font to change the font, size or color of the title and receive the following dialog 
box: 

 
4. Select the font, style, size and color of the table title and click OK 
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5. Click OK in the Table Options dialog box to return to the KD Data Pro window and apply the 
table title changes.  Click Cancel in the Table Options dialog box to cancel your table title 
changes. 

Note: Heading and data font can be changed in the same way title font was changed, by clicking 
on Heading Font or Data Font instead of Title Font, and following the above instructions. 

Setting Time and Location Preferences 

Choosing the Data Range 
Note: By default, any graph, report, or table created, uses all logged data (all locations and total 

logged time). 

This function can be used to limit active data to certain times or locations.  In the KD Data Pro 
window, do the following to set time and location preferences for data logged. 
 

1. From the Data menu, select Time And Location to receive the following dialog box: 

 
2. On the left side of the dialog box, under the Choose Range by heading, click in the 

Location or Time radio button to limit the data range by location or time. 

3. With the Location radio button selected, choose the locations you want to include (you can 
CTRL click or SHIFT click to select multiple locations) to limit the data range by location. 

or 

With the Time radio button selected, fill in the Starting Time and Ending Time boxes to limit 
the data range to specific times. 



 

May-10 © 2010 K.D. Engineering  34

4. Click OK in the Time Options dialog box to return to the KD Data Pro window and apply 
the data range changes.  Click Cancel in the Time Options dialog box to cancel your data 
range changes. 

Notes: The Display All radio button is the default setting under the Choose Range by heading. 

 If changes to the data range are made, any future graph, report or table creation will 
generate a dialog box asking if you want those changes to be present in the new graph, 
report or table. 

Changing the Time Display Options 
This function can be used to change the appearance of the time and date displays, change the Time 
label, as well as choose whether locations are indicated or not.  In the KD Data Pro window, do the 
following to set the time display preferences. 
 
1. From the Data menu, select Time And Location to receive the following dialog box: 

 
2. On the right side of the dialog box, under the Display Options heading, click the Time or Date 

drop down boxes to change the appearance of the time or date. 

3. In the Label box, type in a label for the time and date (the default label is Time for the graph and 
table, and Range for a report). 

4. In the Indicate Locations check box, choose whether or not you want the locations indicated. 

5. Click OK in the Time Options dialog box to return to the KD Data Pro window and apply the 
time display changes.  Click Cancel in the Time Options dialog box to cancel your time display 
changes. 

Note: If changes to the time display are made, any future graph, report or table creation will 
generate a dialog box asking if you want those changes to be present in the new graph, 
report or table. 
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Setting Data Preferences 

Selecting the Type of Data Shown 
This function may be used to limit the types of data shown on your graph, report or table.  In the KD 
Data Pro window, do the following to select what types of data are shown. 
 
1. From the Data menu, select Data Options to receive the following dialog box: 

 
2. Select the type of measurement you wish to hide, for example Carbon Dioxide, Temperature, 

Relative Humidity, Carbon Monoxide.  Click in the Shown check box (if the check is visible, 
the measurement is shown). 

3. Click OK in the Data Options dialog box to return to the KD Data Pro window and apply the 
data display changes.  Click Cancel in the Data Options dialog box to cancel your data display 
changes. 

Note: If changes to the type of data displayed are made, any future graph, report or table creation 
will generate a dialog box asking if you want those changes to be present in the new graph, 
report or table. 
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Selecting Units of Measurement and Data Labels 
This function may be used to select the units of measurement and data labels for data shown on your 
graph, report or table.  In the KD Data Pro window, do the following to select the units of 
measurement and label name for logged data. 
 
1. From the Data menu, select Data Options to receive the following dialog box: 

 
2. Select the type of measurement for which you wish to change the units of measurement or label, 

for example Carbon Dioxide, Temperature, Relative Humidity, Carbon Monoxide. 

3. Use the Units drop down box to select the units of measurement for the selected data type. 

4. In the Label box, type in a label for the type of measurement selected. 

5. Click OK in the Data Options dialog box to return to the KD Data Pro window and apply the 
units of measurement and label changes.  Click Cancel in the Data Options dialog box to cancel 
your changes. 

Note: If changes to the units of measurement or data labels are made, any future graph, report or 
table creation will generate a dialog box asking if you want those changes to be present in 
the new graph, report or table. 
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Selecting Data Measurement Precision 
 
This function may be used to select the precision of data measured.  In the KD Data Pro window, do 
the following to select the precision of data measured. 
 
1. From the Data menu, select Data Options to receive the following dialog box: 

 
2. Select the type of measurement for which you wish to change the precision of data measured, for 

example Carbon Dioxide, Temperature, Relative Humidity, Carbon Monoxide. 

3. In the Precision frame, select either the Auto Rounding radio button, or the digits box radio 
button (Auto Rounding is the default setting). 

4. If you choose the significant digits box your data will be displayed to the specified number of 
significant figures. Type in the number of digits you want your data to be significant to. 

5. If you choose the digits after decimal point box your data will be displayed to a fixed number 
of digits to the right of the decimal point. Type in the number of digits you wish to see after the 
decimal point. 

6. Click OK in the Data Options dialog box to return to the KD Data Pro window and apply the 
precision changes.  Click Cancel in the Data Options dialog box to cancel your changes. 
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Using the File Menu 

Opening a .KD File 
In the KD Data Pro window, do one of the following to open a .KD file. 
 
1. From the File menu, select Open 

or  

click the  button on the toolbar to receive the Open dialog box. 

2. Select the drive or folder the .KD file is located in from the Look in drop down box. 

3. Select the .KD file, and click Open to open the file. 

Closing a .KD File 
In the KD Data Pro window, do the following to close a .KD file. 
 

1. From the File menu, select Close. 
Note: You will be prompted to save the file if changes have been made and not previously saved. 

Saving a .KD File 
In the KD Data Pro window, do one of the following to save a .KD file. 
 
1. From the File menu, select Save 

or  

click the  button on the toolbar to receive the Save dialog box. 

2. Select the drive or folder the .KD file is to be saved in from the Save in drop down box. 

3. Type a file name into the File name box. 

4. Select the type of .KD file you wish to save from the Save as type drop down box. 

5. Click Save to save the .KD file. 
Note: Use Save As from the File menu to rename the file while keeping the previously saved file 

unaltered. 
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Exporting a .KD File 
You can export data to a Comma Separated Value (.CSV) file, a Tab Delimited Text (.TXT) file, or a 
Hyper Text Markup Language (.HTML) file.  These file types can be opened by many spreadsheet 
(e.g., Microsoft Excel), word-processing (e.g., Microsoft Word), and web browser (e.g., Netscape 
Navigator) programs.  In the KD Data Pro window use the following instructions to export data to 
one of the above file types. 
 
1. From the File menu, select Export to receive the Export dialog box. 

2. Select the drive or folder the file is to be saved in from the Save in drop down box. 

3. Type a file name into the File name box. 

4. Select the type of file you wish to save from the Save as type drop down box (e.g., .CSV, .TXT, 
.HTML). 

5. Click Save to export the .KD file as the file type selected. 

Printing a .KD File 
You can print tables, reports, and graphs.  In the KD Data Pro window, do one of the following to 
print a .KD file. 
 
1. From the File menu, select Print 

or  

click the  button on the toolbar to receive the Print dialog box. 
Note: The Print dialog box and Page Setup dialog box are defined by the print driver you use.  

For information on these dialog boxes, see your printer’s documentation or contact your 
printer manufacturer. 

Exiting KD Data Pro Software 
In the KD Data Pro window, do the following to exit the KD Data Pro software. 
 

1. From the File menu, select Exit. 
Note: You will be prompted to save active files if changes have been made and not previously 

saved. 

 


